This tracker is in read-only model To report bugs, please use the appropriate Github repository.

 

Issue152

Title Deform select widget broken in Linux version of Firefox
Priority bug Status resolved
Superseder Nosy List sbrauer
Assigned To Topics

Created on 2010-06-24.09:39:22 by sbrauer, last changed 2010-12-20.13:08:43 by chrism.

Messages
msg469 (view) Author: chrism Date: 2010-12-20.13:08:43
Sure enough.  Thanks for reporting this, it's fixed on the trunk.
msg419 (view) Author: sbrauer Date: 2010-06-24.09:39:22
I've only seen the problem in Firefox on Linux, but it happens consistently from
the few machines I've tried.   Clicking the select pops up the options as
expected, but moving the mouse pops the options back down so they can't be
selected with the mouse (selection with the keyboard still works).   
Seems to be due to nesting the select inside a list item.  Converting the ul and
li tags to divs fixes the problem.
Problem can be reproduced on the demo site (http://deformdemo.repoze.org/select/).
History
Date User Action Args
2010-12-20 13:08:43 chrism set status: unread -> resolved
messages: + msg469
2010-06-24 09:39:22 sbrauer create